Configurare ruta statica pe routere Cisco – Tutorial realizat in GNS3

Configurare noua (How To)

Situatie

O ruta statica comunica unui echipament unde sa trimita traficul. Rutele statice sunt folosite atunci cand reteaua pe care o administram este compusa dintr-un numar restrans de routere.

Solutie

O ruta statica comunica unui echipament unde sa trimita traficul. Rutele statice sunt folosite atunci cand reteaua pe care o administram este compusa dintr-un numar restrans de routere.

 

Sintaxa rutei statice:

ip route destination-network-address subnet-mask {next-hop IP address | exit-interface}

  • Destination-network-address: adresa de retea a retelei la care dorim sa conectam echipamentul
  • Subnet mask: Subnet mask-ul retelei la care dorim sa conectam echipamentul
  • Next-hop IP address: adresa IP configurata pe router-ul la care ne conectam
  • Exit-interface: interfata de pe router-ul pe care il configuram prin care o sa iasa pachetele

 

Pentru tutorialul nostru sa presupunem ca se doreste ca dintr-o retea locala din cele 2 locatii (172.16.1.0/24, 172.16.2.0/24 configurate ca interfete loopback pe routerele R1 si R2 pentru a simula retelele locale) sa se poata comunica cu cealalta retea locala.

In GNS3 trebuie adaugate cele 2 routere, ca in imagine.

rs1

Vom porni routerele apasand butonul de Play (verde).

rs2

Routerele vor fi configurate astfel:

 

Pentru R1:

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#interface s2/1

R1(config-if)#ip address 10.0.0.1 255.255.255.0

R1(config-if)#no shutdown

R1(config-if)#interface lo0

R1(config-if)#ip address 172.16.1.1 255.255.255.0

 

Pentru R2:

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#interface s2/1

R2(config-if)#ip address 10.0.0.2 255.255.255.0

R2(config-if)#no shutdown

R2(config-if)#interface lo0

R2(config-if)#ip address 172.16.2.1 255.255.255.0

 

Acum interfetele routerelor sunt configurate, dar retelele locale inca nu pot comunica (172.16.1.0/24 si 172.16.2.0/24).

Pentru a verifica tabelele de rutare, trebuie sa executam comanda show ip route pe fiecare router.

Pentru R1:

rs3

Pentru R2:

rs4

 

Se observa urmatoarele:

  • Pentru R1 retelele 172.16.1.0 si 10.0.0.0/24 sunt directly connected sau connected (litera C)
  • Pentru R2 retelele 172.16.2.0 si 10.0.0.0/24 sunt directly connected sau connected (litera C)

Pentru a configura rutele statice, trebuie sa rulam urmatoarele comenzi pe routere:

  • Pentru a configura ruta statica pe R1:

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#ip route 172.16.2.0 255.255.255.0 10.0.0.2

  • Pentru a configura ruta statica pe R2:

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#ip route 172.16.1.0 255.255.255.0 10.0.0.1

 

Acum daca verificam din nou tabelele de rutare, vom vedea ca apar si retelele locale.

Pe R1:

rs5

Pe R2:

rs6

Daca verificam conexiunea catre cele 2 retele locale:

De pe R2 catre reteaua locala din spatele routerului R1:

rs7

De pe R1 catre reteaua locala din spatele routerului R2:

rs8

                Atentie!

                Un utilizator din reteaua 172.16.1.0/24 va putea accesa reteaua 172.16.2.0/24 dupa configurarea rutei pe R1. Pentru a configura conectivitatea si din celalalt sens, trebuie configurata ruta statica si pe R2.

 

SPOR!

 

 

Tip solutie

Permanent

Voteaza

(6 out of 8 people found this article helpful)

Despre Autor

Leave A Comment?