Configurare RIPv2 pe routere Cisco – Tutorial realizat in GNS3

Configurare noua (How To)

Situatie

RIPv2 este mai mult o dezolvare a caracteristicilor ale lui RIPv1 si o extensie decat un protocol nou. Unele dintre
aceste caracteristici incorporate includ:
– adresele next-hopurilor incluse in update-urile de rutare
– folosirea adresei de multicast in transmiterea update-urilor
– optiunea de autentificare

 

In acest tutorial vom parcurge impreuna pasii pe care trebuie sa-i urmati pentru a configura RIPv2 pe routerele dumneavoastra.

Solutie

Pasi de urmat

Ca si RIPv1, RIPv2 este un protocol de rutare de tip distance-vector. Ambele versiun de RIP au urmatoarele limitari si
caracteristici:
– utilizarea lui holddown si altor timpi folositi pentru prevenirea buclelor de rutare
– utilizarea tehnicii split horizon care de asemenea ne ajuta la evitarea buclelor de rutare
– utilizarea update-urilor triggered pentru o convergenta mai rapida

Maximul de hopuri fiind 15, atunci cand numaratorul de hopuri ajunge la 16 va semnifica o retea inaccesibila.

RIP trimite intreaga tabla de rutare catre toate interfetele active la un interval de 30 de secunde. (update-urile RIP se transmit la 30 de secunde)

RIPv2 trimite informatii legate de subnet mask odata cu trimiterea tabelei de rutare (classless routing)

RIP foloseste hop-count pentru a determina calea cea mai buna pentru rutare a pachetelor.

Distanta administrativa este de 120

RIPv2 este definita in RFC 1723. Ca si versiunea 1, RIPv2 este incapsulata intr-un segment UDP, foloseste portul 520 si poate retine pana la 25 de rute. Desi RIPv2 are acelasi format de baza ca si RIPv1, sunt adaugate 2 extensii importante.

Prima extensie – in formatul mesajului RIPv2 este subnet mask care permite alocarea a 32 de biti. Astfel, router-ul destinatie nu mai depinde de subnet mask de pe interfata de intrare, sau de masca clasei atunci cand va determina subnet mask pentru o ruta.

Cea de-a doua extensie – adaugarea adresei de Next Hop. Adresa Next Hop este folosita pentru identificarea unei mai bune adrese de next-hop – daca aceasta exista – decat adresa router-ului emitator. Daca acest camp are adresa 0.0.0.0, adresa router-ului emitator este cea mai buna adresa de next-hop.

In continuare vom configura RIPv2 pentru topologia de mai jos:

 

ripv2t1

Vom configura routerele astfel:

Pentru R1:

enable
configure terminal
interface s2/0
ip address 172.16.0.2 255.255.255.0
no shutdown
interface lo0
ip address 192.168.1.1 255.255.255.0
no shutdown

Pentru R2:

enable
configure terminal
interface s2/0
ip address 172.16.0.1 255.255.255.0
no shutdown
interface f0/0
ip address 10.10.0.1 255.255.255.0
no shutdown

Pentru R3:

enable
configure terminal
interface f0/0
ip address 10.10.0.2 255.255.255.0
no shutdown
interface lo0
ip address 192.168.2.1 255.255.255.0
no shutdown

 

Dupa ce am configurat interfetele de pe fiecare router vom  verifica tabelele de rutare.

ripv2t2

ripv2t3

ripv2t4

Vom vedea ca pe cele 3 routere au aparut retelele direct conectate.

In momentul acesta, daca vrem sa dam ping de pe interfata de loopback configurata pe R1 catre interfata de loopback configurata pe R3 vom observa faptul ca routerul R2 nu va sti pe ce interfata sa trimita pachetele catre retelele de loopback.

Trebuie sa activam RIPv2 pe toate cele 3 routere.

 

Pentru R1:

enable
configure terminal
router rip
version 2
network 172.16.0.0
network 192.168.1.0

Pentru R2: 

enable
configure terminal
router rip
version 2
network 172.16.0.0
network 10.10.0.0

Pentru R3:

enable
configure terminal
router rip
version 2
network 10.10.0.0
network 192.168.2.0

 

 

Putem verifica tabelele de rutare dupa configurarea ripv2 pe routere.

ripv2t5

ripv2t6

ripv2t7

 

Pentru a vedea exact cum functioneaza, puteti activa debug ip rip pe fiecare router (dezactivarea se face prin no debug ip rip).

 

Acum veti putea da ping din reteaua 192.168.1.0 (loopback pe R1) in reteaua 192.168.2.0 (loopback pe R3).

 

ripv2t8

Spor!

Tip solutie

Permanent

Voteaza

(3 out of 6 people found this article helpful)

Despre Autor

Leave A Comment?