Configurare RIP pe routere Cisco – Tutorial realizat in GNS3

Configurare noua (How To)

Situatie

Routing Information Protocol sau RIP este unul din cele mai vechi protocoale de rutare folosite de routere dintr-o locatie geografica de mici dimensiuni.

Iata cum configurati acest protocol pe routere cisco.

Solutie

Routing Information Protocol sau RIP este unul din cele mai vechi protocoale de rutare folosite de routere dintr-o locatie geografica de mici dimensiuni.

Specificația originala de RIP a fost definita în RFC 1058 (Iunie 1988) utiliza rutarea pe baza adresării “classfull”. Prin urmare, actualizările periodice, nu includeau și informația de subrețea specifice VLSM, astfel era necesar ca subrețelele existente sa fie toate de aceeași dimensiune. Totodată nu exista suport pentru autentificarea routerelor făcându-l vulnerabil atacurilor asupra rețelei.

RIP este numit si routing by rumor protocol pentru ca el trimite intreaga tabela de rutare catre toti vecinii la un interval de 30 de secunde. Astfel, update-urile privind rutele dintr-o retea se propaga din router in router. Din acest motiv RIP converge foarte incet si reprezinta una din principalele probleme ale acestui protocol.

RIP este cel mai vechi protocol de rutare distance-vector. Desi RIP-ului ii lipseste complexitatea altor protocoale de rutare mai avansate, simplitatea si utilizarea raspandita asigura longevitatea sa. RIP-ul nu este un protocol “pe cale de disparitie”, de fapt, o forma a RIP-ului pentru Ipv6 numita RIPng (noua generatie) este acum valabila.

Caracteristici RIP:

  • RIP este un protocol distance-vector
  • RIP foloseste hop count ca unica metrica pentru selectarea caii.
  • Routerele cunoscute cu hop count mai mare de 15 innaccesibile.
  • Mesajele trimise prin broadcast la fiecare 30 de secunde

Distanta administrativa (AD) este alegerea sigura (sau preferata) a sursei rutei. RIP are o distanta

administrativa setata default de 120.

RIP este un protocol classful de rutare. RIPv1 nu trimite informatie despre subnet mask in update. De aceea, un router ori foloseste subnet mask configurata pe o interfata locala, ori aplica subnet mask asignata din oficiu clasei de adresa. Datorita acestei limitari, reteaua RIPv1 nu poate fi discontinua, dar nici nu poate implementa VLSM.

rip1

Presupunem ca reteaua 172.16.5.0 devine inaccesibila. La urmatorul update RIP, routerul R4 afla ca nu mai poate ruta pachetele prin R5 pentru a ajunge in reteaua 172.16.5.0. La urmatorul update, R2 afla ca nu mai poate ruta pachetele prin R4, dar este informat de R1 ca poate ajunge in reteaua 172.16.5.0 prin el. Se creeaza o bucla: traficul catre reteaua 172.16.5.0 va trece din R3 catre R1, din R1 catre R2, din R2 catre R3 si tot asa.

Pentru a activa un protocol de rutare, se intra in modul de configurare globala si se folosesc comenzile routerului. Pentru a intra in modul de configurare a routerului pentru RIP, se introduce router rip in mediul de configurare globala.

Presupunem urmatorul scenariu:

rip2

Vom configura routerele conform imaginii de mai sus:

R1:

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#interface s2/0

R1(config-if)#ip address 195.14.25.41 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#interface s2/1

R1(config-if)#ip address 195.14.125.49 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#interface e1/0

R1(config-if)#ip address 192.168.10.1 255.255.255.0

R1(config-if)#no shutdown

 

R2:

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#interface s2/0

R2(config-if)#ip address 195.14.25.42 255.255.255.252

R2(config-if)#no shutdown

R2(config-if)#interface s2/1

R2(config-if)#ip address 195.14.125.50 255.255.255.252

R2(config-if)#no shutdown

R2(config-if)#interface f0/0

R2(config-if)#ip address 195.14.30.62 255.255.255.252

R2(config-if)#no shut

R2(config-if)#interface e1/0

R2(config-if)#ip address 192.168.20.1 255.255.255.0

R2(config-if)#no shut

R3:

R3#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R3(config)#interface f0/0

R3(config-if)#ip address 195.14.30.61 255.255.255.252

R3(config-if)#no shutdown

R3(config-if)#interface e1/0

R3(config-if)#ip address 192.168.20.1 255.255.255.0

R3(config-if)#no shut

 

 

RIP-ul trebuie configurat astfel pe fiecare router:

 

Pentru R1:

R1#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R1(config)#router rip

R1(config-router)#network 192.168.10.0

R1(config-router)#network 195.14.25.0

R1(config-router)#network 195.14.125.0

 

Pentru R2:

R2#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R2(config)#router rip

R2(config-router)#network 192.168.20.0

R2(config-router)#network 195.14.25.0

R2(config-router)#network 195.14.125.0

R2(config-router)#network 195.14.30.0

 

Pentru R3:

R3# configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

R3(config)#router rip

R3(config-router)#network 192.168.30.0

R3(config-router)#network 195.14.30.0

 

IP ROUTE va arata astfel:

rip3

rip4

rip5

 

Pentru a vedea cum ajunge un pachet din R3 catre reteaua 192.168.10.1:

rip6

O alta comanda care ne da mai multe detalii legate de RIP:

Show ip protocols

Daca lipseste o retea din tabela de rutare, se controleaza configurarea de rutare folosind comanda show ip protocols. Aceasta comanda afiseaza protocolul de rutare care este configurat pe router. Acest output poate fi folosit pentru a verifica majoritatea parametrilor RIP-ului pentru a confirma daca rutarea RIP este configurata, interfetele corecte primesc si trimit actualizari, routerul anunta retelele corecte, vecinii trimit actualizari.

rip7

 

Spor!

Tip solutie

Permanent

Voteaza

(4 out of 7 people found this article helpful)

Despre Autor

Leave A Comment?