Cum se rezolvă eroarea “Device eth0 does not seem to be present, delaying initialization” pe CentOS instalat in virtualizare.

Rezolvare problema (Fix IT)

Situatie

S-a instalat o masina virtuala pe virtual box si nu se poate conecta la internet. In Virtual Box s-au facut setarile necesare dar la comanda ifconfig in linux nu apare placa de retea eth0.

Simptome

Nu exista conexiune la internet.

Backup

Nu este necesar.

Solutie

Pasi de urmat

Se ruleaza comanda ifconfig pentru a verifica detalii de configurare a placii de retea.

lo Link encap:Local Loopback 
 inet addr:127.0.0.1 Mask:255.0.0.0
 inet6 addr: ::1/128 Scope:Host
 UP LOOPBACK RUNNING MTU:65536 Metric:1
 RX packets:0 errors:0 dropped:0 overruns:0 frame:0
 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
 collisions:0 txqueuelen:0 
 RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Se observa ca nu sunt afisate detaliile complete, fiind afisate doare cele ale interfetei de loopback.

Una din verificarile care se pot face, este sa se citeasca fisierul care contine configurarea placii de retea care se poate gasi in calea /etc/sysconfig/network-scripts/ifcfg-eth0 pentru CentOS 6.*.


HWADDR este adresa fizica a placii, adica adresa MAC. 

Se inchide masina virtuala si mergeri in Virtual Box la Settings -> Network -> Adapter 1 -> Advanced pentru virtualizarea dorita. Acolo se inlocuieste adresa mac existenta cu cea din linux.

Dupa modificare adresei MAC se salveaza si se reporneste masina virtuala.

Pentru a verifica daca setarile s-au efectuat se ruleaza comana ifconfig in consola. Rezultatul trebuie sa arate asemantor cu cel de mai jos.

In momentul de fata conexiunea de internet este functionala.

Tip solutie

Permanent

Plan de restaurare in caz de nefunctionare

Nu este necesar. Modificarile facute sunt asupra programului de virtualizare si nu asupra masini virtuale.

Etichetare:

Voteaza

(13 din 28 persoane apreciaza acest articol)

Despre Autor

Leave A Comment?